Eclipse Ganymede + Subclipse = Unable to load default SVN client???

I like Shiny New Things. So when I heard Eclipse Ganymede SR1 was available, I proceeded to replace the Stream Stable Build I was currently running.

This, of course, ended up causing me problems. After installing Subclipse and attempting to pull up any SVN history, I get an error dialog box that states:
“Unable to load default SVN client”

Confused, I RTFM and saw that “Subclipse 1.4.x requires Subversion 1.5.0 version of JavaHL/SVNKit”

Seeing the SVN I was running was in fact not 1.5,

  [email protected]~ $ svn --version
svn, version 1.4.4 (r25188)
   compiled Nov 25 2007, 08:20:33

I went here, downloaded and installed Subversion 1.5, restarted Eclipse and things are looking good now.

Stupid shiny new things.

Eclipse Ganymede + Subclipse = Unable to load default SVN client???

4 thoughts on “Eclipse Ganymede + Subclipse = Unable to load default SVN client???

  1. Thanks for this post that provided me with the solution to my problem.

    I had this same ‘Unable to load default SVN client’ message after upgraging to Eclipse 3.4 and Subclipse 1.4 and had no clue what was happening since everything used to work fine with Eclipse 3.2.

    I did not even think about RTFM, but you did and you were right…

  2. Nice… I was just setting up my Android dev environment, and I was having a little problem getting subclipse to work, so I googled “Unable to load default SVN client”, and what do you know… I see a noted path. Hey, I know that guy. Thanks Theo.

  3. vwpbl says:

    This did not directly help me, but it pointed me in the right direction. The RTFM suggestion specifically. I had upgraded to was upgrading to 1.6.10 of subclipse and things were not working. Eclipse was giving me this error message. So I checked the subclipse website as noted above and found I had the correct svn version on my computer. TortoiseSVN was not having any issues. Further checking on the subclipse website resulted in me finding this ( http://subclipse.tigris.org/upgrade.html ) advising not to perform ‘updates’. so I uninstalled the subclipse plugin and reinstalled and all is well.

Leave a Reply

Your email address will not be published. Required fields are marked *